Knowledge
The frequently asked questions users encounter on the use of Software and Hardware are collected and here we offer the best possible solutions for your reference.
How to Capture the Simulation Screen Display
Screen capture is always required for users to edit manual guide. There are two ways of capturing the simulation screen display:
A. Capture screen on PC;
B. Use “Screen hard copy” function of EasyBuilder Pro:

A. Capture screen on PC
During on-line simulation or off-line simulation, press “AltPrint Screen” on keyboard to capture the simulation screen. Paste it into an image editing tool and save it.
 
B. Use “Screen hard copy” function of EasyBuilder Pro
1. Open EasyBuilder Pro project file. Create a function key and check the “Screen hard copy” radio box in the general setting window. Set the printer to “USB disk 1”.
 
Notice: It is suggested to create the function key object in the “Common Window”, since that the objects in this window can be applied to all other windows;
 
Click “Object / Button / Function Key”:
2. In the popup window, check the “Screen hard copy” radio box under the “General” tab. Set the printer to “USB disk 1”. Click “OK” to finish
 
3. Start off-line simulation. Click the print button that is created in the previous step to capture the simulation screen and save it as an image file under the path “\usb1\hardcopy”.
  
The image is saved in the following path C:\EasyBuilder Pro\usb1\hardcopy:

Decompile the xob file which uploading in the USB Stick
1.  Upload the program file from HMI to the USB disk, and then copy it to the PC (or use the file in USB disk directly).
 
2.  Check out the file that was previously copied from the HMI in the file browser. The original file doesn’t have extension file name.
 
3.   Add the extension file name “.xob”.
 
4.  Run EasyBuilder Pro, select “Tool / Decompile”. The “Decompile” dialog box pops up.
5.  Click “Browse” button, and find the .xob file that has been added extension name in the previous step.
 
6.  When the .xob file is selected, make sure that the decompile password must be the same as the upload password. Click “Decompile” button to start to decompile. When the “succeeded” message appears, the de-compilation is completed. Click “Exit” to leave.
 
7.  After de-compilation, open the file that was being decompiled (which now becomes *.mtp file). You can edit it using EasyBuilder Pro now.
 
8.  Open the .mtp file, the edit environment is shown below:

How to backup a project
An EasyBuilder Pro project contains the source project file (*.mtp), and a number of library files (*.flb, *.blb, *.plb, *.slb, *.snd, *.lbl, and *.glb). These can be individually copied to another location for archiving, or to select theCompress/Uncompress option from EasyBuilder Pro's Tools menu.

Step 1.
Click Compress/Uncompress from Tools menu.

 

Step 2.
The following dialog is displayed. Click “Browse” to select source project for archiving.


All of the files associated with the project are compressed into a file, with a name of the form *.cmp. The compressed CMP file can be properly archived when this step is successfully completed.

Download Start Up Screen
MT8000/6000 i series HMI supports users to define their own startup screen, such as enterprise trademark logo, etc. The format of the picture used is BMP and can not exceed the resolution.

The assigned BMP picture will be downloaded to HMI. After downloading, HMI will reboot, this picture will be shown after rebooting, and then load in the project. Users are allowed to use their logos as the start up screen through this method.

Note: Only support i series and OS Image 20090415 or later)

    

There are 2 ways to download start up screen as shown below:

1. Project Manager

    1-1 Open Project Manager

    1-2 Click [Download]
    
   

    1-3 Select a BMP picture that suits the size of HMI screen,
           Ex: MT8070iH uses a 800*480 picture.

    1-4 Set the IP address or use a USB cable.

    1-5 Click [Download]; reboot HMI to see the successfully set picture display when HMI starts up.

    

2. EasyBuilder Pro

    2-1 Click [Tool] then select [Download]

   

    2-2 Select a BMP picture that suits the size of HMI screen,
           Ex: MT8070iH uses a 800*480 picture.

    2-3 Set the IP address or use a USB cable

    2-4 Click [Download]; reboot HMI to see the successfully set picture display when HMI starts up.

    

    

EasyBuilder Pro - Alignment
In EasyBuilder Pro, there are two different ways to align the text on the object, one is to click the icons on the toolbar and the other is to set on object setting dialog.
  • By clicking the icons on toolbar (Left Alignment | Center Alignment | Right Alignment), the text, no matter single-lined or multi-lined, will be seen as one single label and will align to the outline of the object.

  • By setting Label>>Align on object setting dialog, the multiple lines of the text will align in the way set. This is a line by line alignment.

  • The line by line alignment of the multi-lined text can be done using Label>>Attribute selection on object setting dialog.

  • If an object is set to [Left] for [Align], when clicking [Left Alignment] on toolbar, the multi-lined text will be aligned along the left edge of the object.

  • The way above is same for [Align Center] and [Align Right]. The multi-lined text will display according to the setting of Label>>Attribute>>Align.

    The illustration below shows when [Left Alignment] icon is clicked, the text content are still displayed in the way they are set in object setting.

  • If object text is set with multiple states, tick [Tracking], in this way when moving text in one state, the texts of other states will also be moved in the same way.

  • Move object text in state 0; check the other states to see if the texts in those states all move the same way as in state 0. If [Tracking] is not selected, only text in one state will be moved.

How to download project by Ethernet

This FAQ explains how to download project file to HMI via Ethernet.

Applicable models: eMT Series, iE Series, XE Series, mTV Series, i Series

Non-applicable models: cMT Series

 

 

HMI Settings

Step 1.      Click on the  Arrow icon in the lower-right corner of the screen.

Step 2.      The following four icons will be shown, click the first Gear icon.

描述: C:\Users\Janecheng\Desktop\筆記本.png

Step 3.      Enter password (default is 111111). If the password is correct, the System Settings window opens.

Step 4.      In Network tab, set the IP address. Select [Obtain IP Address Automatically] to get IP settings automatically, or select [IP address get from below] to specify an IP address. After setting click [Apply] or [OK] to finish.

Step 5.      In Security tab, set the project upload/download password. Click [Download Password] and enter the password. By default, the download password is 111111.

Step 6.      When finish setting and leave System Settings window, click the Arrow icon again. Select the Notepad icon to find the IP address of the HMI.

描述: C:\Users\Janecheng\Desktop\齒輪.png

 

PC Settings

Step 1.      Click the Start button and then click [Control Panel]. Under [Network and Sharing Center] click [View network status and tasks]. Click [Local Area Connection] » [Properties], and then double click [Internet Protocol Version 4 (TCP/IPv4)] to open the settings page.

Step 2.      Set the network on PC to the same settings as HMI. For example, as shown in the preceding figure, the HMI IP is 192.168.1.100, so the IP of the PC should be 192.168.1.xxx, where x stands for any number.

Step 3.      To download the project, set the IP and download password in Download window.

描述: C:\Users\Janecheng\Desktop\Download.jpg

 

 

 

Download PDF


 

Notes on USB Cable

The following are some important points relevant to USB cable:

HI-SPEED USB Revision 2.0 SHIELDED 24AWG

1. The PC must support USB 2.0 or USB 3.0.


2. Use a double shielding USB cable: Foil + Braid Shield.


3. The length of the cable should be limited to less than 1.8 meters.

4. If a desktop is used, the USB cable must be plugged into the back panel instead of the front. If a laptop is used, please remove the external power supply.

5. When downloading a project through USB cable, please remove all the other devices that are connected to HMI.

6. If download fails, the possible cause can be the incompatible USB driver on PC. Go to Computer Management » Device Manager to check if the correct USB driver is installed. If not, please go to the installation folder of EasyBuilder and find the usbdriver folder, to manually update the driver.



How to use the VNC server?

The VNC server is a standard feature on the HMI, allowing users to monitor HMI screen through a VNC client program.

Step 1. Enable the VNC server on the HMI. A single-connection allows only one VNC client connection at a time, while there is no such restriction for multi-connection.


Step 2.
The default VNC login password is 111111, which can be changed on the VNC server.


Step 3. Use a third-party VNC client program, enter the HMI's IP and Port (5900), then proceed by entering the login password to access the HMI screen.


TCP Port List

This FAQ introduces the TCP ports used for certain HMI features.



Download PDF



How to use the fonts not supported in EasyBuilder?

Certain fonts can be used in Microsoft Office but cannot be used in EasyBuilder. The possible reason is that these fonts have different names in Control Panel on PC and in Windows Registry. Therefore in EasyBuilder these fonts cannot be selected and used. This document explains the solution to use these font files in EasyBuilder.

 

Supported software version:

EB8000 V465.05 and later versions

EBPro V300.03 and later versions

A.

 

Step 1.            Use Microsoft Office Word to check if the font can be displayed correctly. If not, copy the font file to Control Panel\Fonts and restart EasyBuilder to check again.

Step 2.            If the font is still not displayed in EasyBuilder, check if it works in Word. If it displays correctly in Word, copy the font file from Control Panel\Fonts to EasyBuilder\Windows_font folder and restart EasyBuilder to check again.

 

When finished, if the font still cannot be displayed in EasyBuilder, the reason would be the difference in font names. For example, the font name in Word is in double-byte characters (As in Traditional Chinese, Simplified Chinese, Korean, Japanese etc.) where in Windows Registry it uses an English name, or, it uses English name in Word where a double-byte character name is used in Windows Registry. The following steps explain the solution.

Example 1

The Korean font “휴먼옛체uses a Korean font name in Word but an English font name in Windows Registry.

 

Step 1.            Copy “휴먼옛체” font file from Control Panel\Fonts to the desktop to see the font name.


Step 2.            Run Microsoft Registry Editor (Regedit). Under the directory: \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts, find the corresponding name of the font. As shown in the following figure, the corresponding font name of 휴먼옛체 is Yet R.


Step 3.            Open the FontTableName.xls file under EasyBuilder installation directory and enter the English font name in column A, and the Korean font name in column D.


Step 4.            Restart EasyBuilder to select the font.


Example 2

The Chinese font 方正大标宋繁体 uses an English font name in Word but a Chinese font name in Windows Registry.

 

Step 1.            Copy 方正大标宋繁体 font file from Control Panel\Fonts to the desktop to see the file name.

 

Step 2.            Run Microsoft Registry Editor (Regedit). Under the directory: \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts, find the corresponding name of the font.


Step 3.            Open the FontTableName.xls file under EasyBuilder installation directory, enter the English font name in column A, and the Chinese font name in column B. (If the Simplified Chinese OS is used, enter the Chinese font name in column C.)


Step 4.            Restart EasyBuilder to select the font.

 

Note:

n      The columns in FontTableName.xls correspond to specific languages and therefore cannot be modified or deleted.

n      When using Simplified Chinese font file in Traditional Chinese OS, the Chinese font name entered in FontTableName.xls should be in column B, not column C.

 

How to do floating point calculations with integers?


To gain a result with decimal place when dividing integers, please convert the integer to float first.

Please see the following Macro. D8=5 is the integer value gained from PLC.

 



Line 10: Since D8 is an integer, D8/10 is performed as an integer operation and the result is 0. The result is then written to a float variable, float_D8, therefore float_D8 is 0.0.

Line 15: Since temp is a float, temp/10 is performed as a float operation and the result is 0.5.


Download PDF

How to correctly display the project content in different DPI settings?

The computer display resolution is getting higher and higher, in order to display the text clearer, changing the DPI is a choice. However, this also influences the EasyBuilder project display. Incorrect display can happen due to the difference in DPI settings from one computer to another. To avoid this, please follow the steps to adjust the DPI setting.

Checking the current size of text

Step 1. Click the right mouse button on the desktop and select [screen resolution] » [Resolution]。


Adjusting the DPI of EasyBuilder project

Step 1. Launch EasyBuilder Pro, select [Tools] » [Text DPI Setting].


Step 2. Choose [Select the previous PC’s text DPI setting], adjust the DPI to the same setting as the previous computer used to create this project. The text will be correctly displayed. Click [OK]; the system will generate a BAK file for future reference.

Step 3. The DPI setting will be stored in the system. Next time when opening this project file, the previous PC’s DPI setting will be used.


Download PDF

 
How to Connect Multiple Devices via One Serial Port?

To connect multiple devices via a single serial port, certain station number can be specified when configuring the serial port in System Parameter Settings » Device List. This FAQ explains the syntax of the variables that can be used when setting the station number for the read/write address of an object.

When setting the read/write address of an object, use the syntax “SN#address”. As shown in the following figure, 2#1 indicates station number 2, address 3x1.


Or, use syntax “VARn#address”. The valid VARn range is from LW-10000 (VAR0) to LW-10015 (VAR15). As shown in the following figure, VAR5#2 indicates that the station number is determined by the value in LW-10005 (VAR5).

How to Backup Data to Server and Update in Excel?

To update data backup in remote backup server to an Excel file, please follow the steps below.

 

For details of Backup object settings in EasyPrinter and EasyBuilder, see Chapter 26 EasyPrinter and Chapter 13.24 Backup.

Step 1.       In EasyPrinter, under Convert Batch File select [Enable] check box. This enables converting file backup into Excel file.

 

Step 2.       When backup file to server, a .csv file is generated.



 

Step 3.       Create a new Excel file.



 

Step 4.       Open the created Excel file, import the content in the .csv file by clicking [Data] \ [Get External Data] \ [From Text].



 

Step 5.       During import, select [Comma] to be the delimiters.



 

Step 6.       When finished, the content in the .csv file can be viewed in Excel. Click [Data] and set [Properties].



 

Step 7.       Set the time interval to refresh the Excel file, and select [Refresh data when opening the file].



 

Step 8.       In this way, when backup file to server, the generated .csv file is automatically imported to Excel, therefore users can always view the updated data when opening the Excel file.

 

 

Download PDF

 

 

How to set the HMI IP address on the HMI?

For cMT / cMT X Series:
Step 1. Tap the round button in the upper-left corner (default) of the HMI screen.


Step 2. The [System Setting] window will appear. Tap the lock icon.


Step 3. Enter the password (default is 111111) to access the system settings.


Step 4. In the Network page, select the desired network interface (Ethernet 1 / Ethernet 2).


Step 5. Choose either to obtain an IP address automatically or manually set it. Tap [OK] to save the settings.
[Obtain an IP address automatically]=ON: Automatically obtain IP.

[Obtain an IP address automatically]=OFF: Manually set IP.


Step 6. After exiting [Network], tap [Information] to view the current HMI IP settings under Ethernet 1.


For eMT, iE, XE, mTV, iP Series, etc.:
Step 1. Tap the arrow icon  in the lower-right corner of the HMI screen.
Step 2. Four icons will appear. Tap the first gear icon.


Step 3. Enter the password (default is 111111) to access the system settings.

In the Network tab, select either:
[Obtain an IP Address Automatically]: Automatically obtain IP.
[IP address get from below]: Manually set IP.
After configuring, tap [Apply] or [OK] to save the settings.

Step 4. Exit the system settings window, then tap the arrow icon again and select the notepad icon to view the current HMI IP settings in the Network tab.


How to display project in portrait mode on HMI

If the project file is edited in portrait mode, the following settings help to display project correctly on HMI.


Step 1.       On HMI, open [System settings] » [OS setting], and select [90] or [270] in Portrait Mode group box.

Applicable models: eMT, iE, XE, mTV, i Series



For cMT-iV5 model, open [Setting] » [General] » [Direction] to set portrait mode.



Step 2.       Launch EasyBuilder, click [File] » [New] and select [Portrait] as display mode.


Please note that setting project in Portrait mode before editing the project is necessary. During project editing, the display mode cannot be changed.

 

 

Download PDF


 

Why can’t I open cMT Viewer or the screen is blank after opening cMT Viewer?

 

When using an older computer to open cMT Viewer, sometimes the system may show error message or the screen may be blank. This document shows how to solve this issue.

 

 

The cMT Viewer application requires a 3D graphic API, OpenGL (Open Graphics Library) newer than version 2.1. If you use an older PC or laptop that runs the OS like Windows XP or Windows Vista, the driver of the graphic chips may be outdated, and doesn’t support newer version’s OpenGL. Please download the latest driver of the graphic chip from the supplier.

 

 

Download PDF

 

 

How to change the HMI model in the project?

Adapting the project model to meet diverse customer needs is a common practice. By streamlining this process, significant reductions in both time and costs associated with unnecessary edits can be achieved. Below is an example demonstrating a smooth transition from MT8103iE (1024 x 600) to cMT3108XP (1280 x 800).

Step 1. Open EasyBuilder Pro with the file for MT8103iE.
Step 2. Go to [Home] » [System Parameters] » [Model] » [HMI model], then choose cMT3108XP (1280 x 800).


Step 3. After pressing OK, select window and object adjustments in the "Resize Windows/Objects" dialog box, which appears due to the varying resolutions of HMI models. Then, recompile and download the project to the new model.


Step 4. After pressing OK, if converting from the MT Series to the cMT/cMT X Series, an additional Project Migration Report will appear. This report informs about the automatic changes made by EasyBuilder Pro.


Note: 
The files from the cMT/cMT X Series cannot be converted to MT Series files.

Port Number 8000 Occupied

 


When running project simulation on PC, if the following message is displayed, the possible reason is that the communication port number 8000 is occupied by other application, and therefore the simulation cannot be carried out. This FAQ explains how to check and change port number to solve this problem.

  



 

 

Step 1.   Please use TCPView to check if port no. 8000 is occupied. You can download TCPView using the following link:

 

https://technet.microsoft.com/en-us/sysinternals/tcpview.aspx

 

 



 

Step 2.   If port no. 8000 is occupied, you can change the port number in EasyBuilder System Parameter Settings » Model tab.

 



 

Download PDF

 

 


 

 

How to download project and history data using USB disk or SD card


Utility Manager can build download data and save the data in USB disk or SD card. The data such as project file, recipe data, and history data can be downloaded to HMI using the USB disk or SD card, as a way to update HMI data.

Please note that the described methods are not applicable for cMT Series.

In this document, “USB/SD” refers to USB drive or SD card.

 

 

[Build Download Data for SD/USB Disk]

In Utility Manager click [Publish] » [Build Download Data for SD/USB Disk] to create downloadable data including project file, recipe data, or history data…etc. into USB/SD.

Step 1.       Launch Utility Manager and click [Publish] » [Build Download Data for SD/USB Disk].

Step 2.       Specify the directory of the USB disk or SD card, and the directory of data files, and then click [Build]. For ease of file management, it is recommended that a dedicated folder be created in the USB/SD. You can use a folder name that’s easy to identify, for example, the HMI name or model name.

As shown in the following figure, the folder to save download data is:

G:\MT8100iE



Step 3.   If the data is successfully built, a notification message ‘creating successful!’ will show.

 

 

 

[Download to HMI]

Step 4.    Insert USB disk or SD card into HMI, the following window will be displayed.



Step 5.   Hit [Download], enter HMI download password, select [Download project files] or [Download history files], and then hit [OK]


 

Note: History file includes recipe data (RW, RW_A), and data sampling.

Step 6.   Select the directory that has the download file and then hit [OK]. Choose the same directory whether downloading only the project file, only the history data, or both. As shown in the following figure, select the MT8100iE folder created in step 2.



Step 7.   During download, the message: “Download Project Files…” or “Download History Files…” is displayed.



Step 8.   After download, HMI program will start again.

 

 

Download PDF


 

How to reset HMI to default?

When you need to clear all items and data, restore to factory settings, or if you have forgotten the system settings password and need to reset it to the default value, follow the steps below.

Please note that resetting to factory settings will restore all passwords to the default value "111111" and will clear all projects and historical data. Additionally, system setting parameters will be restored to default values, including network and VNC server settings.

For cMT / cMT X Series

a. Using the Reset Options in system settings:

For OS versions before 20231201:
   
Step 1. Enter the system settings password. If you have forgotten the password, enter "default111111" in the password field and proceed to step 3 directly.


Step 2. Find Reset Options / Reset HMI to Default and click [Start].


Step 3. Follow the on-screen prompt to enter "yes" and click [OK], the system will begin the reset process.


For OS versions after 20231201:

Step 1. Find System Properties / Reset HMI to Default option.


Step 2. Enter the system settings password. If you have forgotten the password, enter "default111111" in the password field and proceed.


Step 3. Tap [Reset], the system will begin the reset process.



b. If your HMI supports DIP switches, you can use them for reset:
   
Step 1. Set DIP SW1 to ON position.
Step 2. Power on your HMI again.
Step 3. After booting, follow the on-screen prompts to perform touch calibration.
 
Step 4. Once calibration is completed, follow the on-screen prompts to restore to factory settings.

For non-cMT / cMT X Series

a. Enable the Reset HMI to Default option in system settings:
   
Step 1. Enter the system settings password.


Step 2. In the Misc 2 tab, select “Enable [Reset HMI to default] button in calibration mode” and tap [OK] to save the settings.


Step 3. Power on the HMI again and long press the screen to enter touch calibration mode. After touch calibration is completed, tap [RESET HMI TO DEFAULT] and follow the on-screen prompts to restore to factory settings.



b. Enable the Reset HMI to Default option via EasyWatch:
   
Step 1. Connect EasyWatch to the HMI, set LB-12364 to True to display [RESET HMI TO DEFAULT] in touch calibration mode. After setting up, follow the steps in the previous section to reset the system.



c. If your HMI supports DIP switches, you can use them for reset:

Step 1. Set DIP SW1 to ON position.
Step 2. Power on your HMI again.
Step 3. After booting, follow the on-screen prompts to perform touch calibration.
Step 4. Once calibration is completed, follow the on-screen prompts to restore to factory settings.